x

Давайте мы вам перезвоним!

Оставьте свой номер и мы перезвоним в течении нескольких минут

ФИО

Номер телефона

В какое время вам перезвонить ?

Ваша заявка отправлена

Закрыть
👁50
02.07.2020

Apache Guacamole

Уязвимость позволяет злоумышленникам получить полный контроль над сервером Guacamole.

Специалисты Check Point Research обнаружили множественные уязвимости в реализации протокола RDP в популярном приложении Apache Guacamole, используемом системными администраторами для удаленного доступа и управления Windows- и Linux-машинами. С их помощью злоумышленники могут получить полный контроль над сервером Guacamole, перехватывать и контролировать все остальные подключенные сеансы.

По словам специалистов, уязвимости позволяют «атакующему, который уже успешно скомпрометировал компьютер внутри организации, запускать атаки на шлюз Guacamole, когда ничего не подозревающий работник пытается подключиться к инфицированной машине».

В ходе аудита безопасности FreeRDP 2.0.0 в январе 2020 года специалисты Check Point Research обнаружили ряд уязвимостей. Две из них объединены под идентификатором CVE-2020-9497. Проблемы затрагивают реализацию протокола RDP, используемую для обработки аудио-пакетов от сервера (rdpsnd). Первая уязвимость позволяет с помощью вредоносного сообщения rdpsnd читать данные за пределами выделенной области памяти по примеру Heartbleed. Вторая уязвимость – передача данных за пределами выделенной области памяти подключенному клиенту. Третья уязвимость аналогична предыдущей и затрагивает канал guacai, ответственный за входящие аудиоданные и отключенный по умолчанию.

Уязвимость CVE-2020-9498 присутствует в guac_common_svc.c из-за нарушения безопасности памяти, что приводит к появлению висячей ссылки, позволяющей атакующему выполнить произвольный код.

С помощью уязвимостей CVE-2020-9497 и CVE-2020-9498 вредоносный корпоративный компьютер может контролировать процесс guacd, когда удаленный пользователь пытается подключиться к своему зараженному компьютеру.

Специалисты в установленном порядке сообщили Apache об уязвимостях 31 марта 2020 года, и в июне они были исправлены.